Ubuntu et les processeurs Intel Skylake, Canonical présente ses excuses, explications

Spread the love

Canonical présente ses excuses aux utilisateurs de son système d’exploitation Linux Ubuntu. Dans un avis de sécurité l’entreprise évoque la « régression » introduite par la dernière mise à jour du microcode Intel.

Le 12 novembre 2019, Canonical a publié d’importantes mises à jour de sécurité du noyau Linux . Cette maintenance a concerné toutes les versions d’Ubuntu prises en charge. L’objectif a été de résoudre différents soucis dont les problèmes CVE-2019-11135 et CVE-2019-11139. Ils affectent les processeurs Intel ( Transactional Synchronization Extensions (TSX)).

Ubuntu, Canonical publie d’importantes mises à jour de sécurité, détails

La première vulnérabilité pouvait permettre de récupérer des informations sensibles dans des tampons micro architecturaux. La seconde faille pouvait provoquer un déni de service (plantage du système).

Ubuntu et les processeurs Intel Skylake

Cependant, cette maintenance a introduit une « régression ». Elle est à l’origine d’un blocage des systèmes Ubuntu dotés d’un processeur Skylake après un redémarrage à chaud. Cette défaillance affecte toutes les versions prises en charge dont Ubuntu 19.10, 19.04, 18.04 LTS et Ubuntu 16.04 LTS.

Dans son avis USN-4182-3 en date du 4 décembre 2019, Canonical explique

« USN-4182-1 a introduit une régression dans le microcode processeur Intel. Certains processeurs Skylake se sont bloqués après un redémarrage à chaud. Cette mise à jour rétablit le microcode de cette famille spécifique. Nous nous excusons pour le désagrément.»

Tous les utilisateurs Ubuntu équipés de processeurs Skylake sont fortement invités à procéder ç une mise à jour de leur distribution pour rétablir la situation. Il est nécessaire d’installation le microcodes Intel v3.20191115. Cette mise à jour est disponible. Pour mettre à jour sa distribution Ubuntu il est nécessaire d’exécuter la commande ci-dessous, puis de redémarrer le PC afin que les changement prennent effet.

sudo apt-get update && sudo apt-get install intel-microcode

Leave a Reply